Require.js

Dataset now ships a build that can be used with require.js. There is a specific build that includes require support and it is miso.ds.X.X.X.m.js. Note that this build does not include dependencies because you are supposed to manage those with require. You will need to include "moment" and "lodash/underscore" as dependencies.

For example, you can require dataset like so:

You can then require it in your actual module definitions like so: